CVE-2024-0760
- EPSS 4.68%
- Veröffentlicht 23.07.2024 15:15:03
- Zuletzt bearbeitet 15.04.2026 00:35:42
A malicious client can send many DNS messages over TCP, potentially causing the server to become unstable while the attack is in progress. The server may recover after the attack ceases. Use of ACLs will not mitigate the attack. This issue affects B...
CVE-2024-1737
- EPSS 2.11%
- Veröffentlicht 23.07.2024 15:15:03
- Zuletzt bearbeitet 15.04.2026 00:35:42
Resolver caches and authoritative zone databases that hold significant numbers of RRs for the same hostname (of any RTYPE) can suffer from degraded performance as content is being added or updated, and also when handling client queries for this name....
CVE-2024-1975
- EPSS 2.11%
- Veröffentlicht 23.07.2024 15:15:03
- Zuletzt bearbeitet 15.04.2026 00:35:42
If a server hosts a zone containing a "KEY" Resource Record, or a resolver DNSSEC-validates a "KEY" Resource Record from a DNSSEC-signed domain in cache, a client can exhaust resolver CPU resources by sending a stream of SIG(0) signed requests. This ...
CVE-2023-50387
- EPSS 100%
- Veröffentlicht 14.02.2024 16:15:45
- Zuletzt bearbeitet 04.11.2025 19:16:14
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that,...
CVE-2023-50868
- EPSS 81.73%
- Veröffentlicht 14.02.2024 16:15:45
- Zuletzt bearbeitet 23.12.2025 20:20:08
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka...
CVE-2023-6516
- EPSS 1.11%
- Veröffentlicht 13.02.2024 14:15:46
- Zuletzt bearbeitet 21.11.2024 08:44:00
To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database. It uses several methods, including some that are asynchronous: a small chunk of memory pointing to the cache element that ca...
CVE-2023-4408
- EPSS 1.34%
- Veröffentlicht 13.02.2024 14:15:45
- Zuletzt bearbeitet 14.03.2025 17:15:40
The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` insta...
CVE-2023-5517
- EPSS 1.24%
- Veröffentlicht 13.02.2024 14:15:45
- Zuletzt bearbeitet 21.11.2024 08:41:55
A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an a...
CVE-2023-5679
- EPSS 1.24%
- Veröffentlicht 13.02.2024 14:15:45
- Zuletzt bearbeitet 29.03.2025 00:15:16
A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18...
CVE-2023-5680
- EPSS 0.63%
- Veröffentlicht 13.02.2024 14:15:45
- Zuletzt bearbeitet 21.11.2024 08:42:15
If a resolver cache has a very large number of ECS records stored for the same name, the process of cleaning the cache database node for this name can significantly impair query performance. This issue affects BIND 9 versions 9.11.3-S1 through 9.11....